个人随笔和一些网文摘录
http://www.dlxp.cn

RouterOS HTB反向标记P2P + 端口优先限速脚本

RouterOS HTB反向标记P2P + 端口优先限速脚本(10M)(修正)

以下内容转于死性不改,更多内容请移步察看。

# mar/07/2011 00:37:18 by RouterOS 3.30
# software id = ZHFH-3UWD
#
/interface bridge
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes \
    comment="" disabled=no forward-delay=15s max-message-age=20s mtu=1500 \
    name=bridge priority=0x8000 protocol-mode=none transmit-hold-count=6
/interface bridge port
add bridge=bridge comment="" disabled=no edge=auto external-fdb=auto horizon=\
    none interface=WAN path-cost=10 point-to-point=auto priority=0x80
/interface bridge settings
set use-ip-firewall=no use-ip-firewall-for-pppoe=no use-ip-firewall-for-vlan=\
    no
/ip firewall mangle
add action=jump chain=prerouting comment="" disabled=yes jump-target=LoadHost
add action=accept chain=prerouting comment="" disabled=yes
add action=mark-connection chain=postrouting comment="" disabled=no \
    new-connection-mark=UP_Conn out-interface=bridge passthrough=yes
add action=mark-packet chain=forward comment="" connection-mark=UP_Conn \
    disabled=no new-packet-mark=UP_Packet passthrough=yes
add action=mark-connection chain=prerouting comment=\
    "\D3\C5\CF\C8\B6\CB\BF\DA" disabled=no dst-port=443 new-connection-mark=\
    Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    8000 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=DNS disabled=no dst-port=\
    53 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=CS disabled=no dst-port=\
    27005 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    27015-27017 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=DNF disabled=no \
    new-connection-mark=Port_Conn passthrough=yes protocol=udp src-port=5063
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    7100-7105 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    10001-10060 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    12010-12190 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\C4\A7\CA\DE\CA\C0\BD\E7" disabled=no dst-port=3724 new-connection-mark=\
    Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    35588 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    1119 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    4000 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    6112-6114 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    7081 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    8081 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    8444-8460 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    38335 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    7081 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    8444-8460 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=\
    "\C4\A7\CA\DE\D5\F9\B0\D4" disabled=no dst-port=1160 new-connection-mark=\
    Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=\
    "\D3\C0\BA\E3\D6\AE\CB\FE" disabled=no dst-port=7777 new-connection-mark=\
    Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    10241 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    16763 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    16763 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=\
    "\CC\EC\C1\FA\B0\CB\B2\BF" disabled=no dst-port=3725-3736 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="QQ\EC\C5\CE\E8" \
    disabled=no dst-port=31414 new-connection-mark=Port_Conn passthrough=yes \
    protocol=tcp
add action=mark-connection chain=prerouting comment="QQ\B7\C9\B3\B5" \
    disabled=no dst-port=2269 new-connection-mark=Port_Conn passthrough=yes \
    protocol=udp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    39311 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    17995 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=\
    "\BD\A3\CF\C0\C7\E9\D4\B5\C8\FD" disabled=no dst-port=3114-3118 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\BA\C6\B7\BD\D3\CE\CF\B7\C6\BD\CC\A8" disabled=no dst-port=1531 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    1080 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    1203 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    5050 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    1509-1513 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    1201 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    1203 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="\D5\BD\B5\D82" disabled=\
    no dst-port=55125-55135 new-connection-mark=Port_Conn passthrough=yes \
    protocol=udp
add action=mark-connection chain=prerouting comment="\C5\DD\C5\DD\CC\C3" \
    disabled=no dst-port=3838 new-connection-mark=Port_Conn passthrough=yes \
    protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    4848 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    5858 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    7878 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    54321 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="\D0\C2\D6\A3\BA\CD" \
    disabled=no dst-port=4001 new-connection-mark=Port_Conn passthrough=yes \
    protocol=tcp
add action=mark-connection chain=prerouting comment="\B0\C1\CA\C0" disabled=\
    no dst-port=4301 new-connection-mark=Port_Conn passthrough=yes protocol=\
    tcp
add action=mark-connection chain=prerouting comment=\
    "\C4\A7\D3\F2&\BC\A4\D5\BD" disabled=no dst-port=5816 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    9958 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    9528 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\B4\AB\C6\E6&4f&\CA\C0\BD\E7" disabled=no dst-port=7000-7003 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    7100 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    7200-7205 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    7300 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    7400 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\B7\B4\BF\D6\BE\AB\D3\A2\D4\DA\CF\DF" disabled=no dst-port=8013 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="QQ&\CB\AE\E4\B0Q\B4\AB" \
    disabled=no dst-port=8000 new-connection-mark=Port_Conn passthrough=yes \
    protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\B4\F3\BB\B0\CE\F7\D3\CE" disabled=no dst-port=3488 new-connection-mark=\
    Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    13388 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="\B5\B6\BD\A3OL" \
    disabled=no dst-port=15269 new-connection-mark=Port_Conn passthrough=yes \
    protocol=udp
add action=mark-connection chain=prerouting comment="\BE\A2\CE\E8\CD\C5" \
    disabled=no dst-port=25510-25530 new-connection-mark=Port_Conn \
    passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\CC\D8\D6\D6\B2\BF\B6\D3" disabled=no dst-port=27930-27931 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\B7\E7\BB\F0\D6\AE\C2\C3" disabled=no dst-port=20001 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\C5\DC\C5\DC\BF\A8\B6\A1\B3\B5" disabled=no dst-port=39311 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    36567 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="\CC\EC\CF\C2\B7\A1" \
    disabled=no dst-port=32040 new-connection-mark=Port_Conn passthrough=yes \
    protocol=tcp
add action=mark-connection chain=prerouting comment="\CE\CA\B5\C0" disabled=\
    no dst-port=9010 new-connection-mark=Port_Conn passthrough=yes protocol=\
    tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    9012 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="QQ\BB\AA\CF\C4" \
    disabled=no dst-port=5128-5132 new-connection-mark=Port_Conn passthrough=\
    yes protocol=tcp
add action=mark-connection chain=prerouting comment="\BB\FA\D5\BDOnline" \
    disabled=no dst-port=9528 new-connection-mark=Port_Conn passthrough=yes \
    protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    3731-3736 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="QQ\D2\F4\CB\D9" \
    disabled=no dst-port=28008 new-connection-mark=Port_Conn passthrough=yes \
    protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    5131 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\CD\EA\C3\C0\CA\C0\BD\E7&\CE\E4\C1\D6\CD\E2\B4\AB" disabled=no dst-port=\
    29000 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    29000 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=\
    "\BE\AA\CC\EC\B6\AF\B5\D8" disabled=no dst-port=38117 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\C8\C8\D1\AA\BD\AD\BA\FE" disabled=no dst-port=1300 new-connection-mark=\
    Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    13000-13009 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\B4\AB\CB\B5OL&\B7\E7\D4\C6" disabled=no dst-port=2346-2347 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\B3\AC\BC\B6\CE\E8\D5\DF" disabled=no dst-port=7000 new-connection-mark=\
    Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    15010 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\B4\F3\BB\B0\CE\F7\D3\CE3" disabled=no dst-port=10613 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\B4\F3\CC\C6\B7\E7\D4\C6" disabled=no dst-port=31001 \
    new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="\D5\F7\CD\BE" disabled=\
    no dst-port=6020 new-connection-mark=Port_Conn passthrough=yes protocol=\
    tcp
add action=mark-connection chain=prerouting comment=\
    "\B4\F3\CC\C6\BA\C0\CF\C0" disabled=no dst-port=6045 new-connection-mark=\
    Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="\BE\DE\C8\CB" disabled=\
    no dst-port=6062 new-connection-mark=Port_Conn passthrough=yes protocol=\
    tcp
add action=mark-connection chain=prerouting comment=\
    "QQ\BB\C3\CF\EB&QQ\C8\FD\B9\FA" disabled=no dst-port=6299 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\CE\E4\C1\D6\C8\BA\CF\C0\B4\AB" disabled=no dst-port=6877 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="\BB\AA\CF\C4ONLINE" \
    disabled=no dst-port=1188 new-connection-mark=Port_Conn passthrough=yes \
    protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    1488-1492 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\B9\A6\B7\F2\CA\C0\BD\E7" disabled=no dst-port=5052 new-connection-mark=\
    Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\BD\A3\CF\C0\CA\C0\BD\E7" disabled=no dst-port=6047 new-connection-mark=\
    Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=Winbox disabled=no \
    dst-port=8291 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="\D1\B0\CF\C9" disabled=\
    no dst-port=1448 new-connection-mark=Port_Conn passthrough=yes protocol=\
    tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    8448 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    15002 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=\
    "\C3\CE\BB\C3\CE\F7\D3\CE" disabled=no dst-port=10616 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    22288 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "QQ\B6\D4\D5\BD\C6\BD\CC\A8" disabled=no dst-port=1671 \
    new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    7000 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    7100 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=\
    "\BD\A3\CF\C0\C7\E9\D4\B5" disabled=no dst-port=6660-6672 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="\B7\E2\C9\F1\B0\F12" \
    disabled=no dst-port=8888 new-connection-mark=Port_Conn passthrough=yes \
    protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\B7\EF\CE\E8\CC\EC\BD\BE" disabled=no dst-port=6000 new-connection-mark=\
    Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=\
    "\B3\C9\BC\AA\CB\BC\BA\BA" disabled=no dst-port=8445-8450 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    17704-17706 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    8445-8450 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=\
    "QQ\BB\C3\CF\EB\CA\C0\BD\E7" disabled=no dst-port=6631-6641 \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="\CA\F1\C3\C5" disabled=\
    no dst-port=7002 new-connection-mark=Port_Conn passthrough=yes protocol=\
    tcp
add action=mark-connection chain=prerouting comment="\EC\AE\B3\B5" disabled=\
    no dst-port=42001 new-connection-mark=Port_Conn passthrough=yes protocol=\
    tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    8451 new-connection-mark=Port_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    8451 new-connection-mark=Port_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="\C1\FA\D6\AE\B9\C8" \
    disabled=no dst-port=14401 new-connection-mark=Port_Conn passthrough=yes \
    protocol=tcp
add action=mark-connection chain=prerouting comment=wow-wt disabled=no \
    new-connection-mark=Port_Conn passthrough=yes protocol=tcp src-port=1080
add action=mark-connection chain=prerouting comment=Ping disabled=no \
    new-connection-mark=Port_Conn passthrough=yes protocol=icmp
add action=mark-packet chain=prerouting comment="\D3\CE\CF\B7\B1\EA\BC\C7" \
    connection-mark=Port_Conn disabled=no new-packet-mark=Port_Packet \
    passthrough=no
add action=mark-packet chain=postrouting comment="" connection-mark=Port_Conn \
    disabled=no new-packet-mark=Port_Packet passthrough=no
add action=mark-connection chain=prerouting comment=\
    "web\B6\CB\BF\DA\D3\C5\CF\C8" disabled=no dst-port=80 \
    new-connection-mark=80_Conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    80 new-connection-mark=80_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    8080 new-connection-mark=80_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    8000-8005 new-connection-mark=80_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    8080 new-connection-mark=80_Conn passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting comment="" connection-mark=80_Conn \
    disabled=no new-packet-mark=80_packet passthrough=no
add action=mark-packet chain=postrouting comment="" connection-mark=80_Conn \
    disabled=no new-packet-mark=80_packet passthrough=no
add action=mark-connection chain=prerouting comment="\CC\DA\D1\B6QQ" \
    disabled=no dst-port=6000-6005 new-connection-mark=Other_Conn \
    passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    8000-8005 new-connection-mark=Other_Conn passthrough=yes protocol=udp \
    src-port=4000-4005
add action=mark-connection chain=prerouting comment="QQ\D6\B1\B2\A5" \
    disabled=no new-connection-mark=Other_Conn passthrough=yes port=1863 \
    protocol=udp
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes port=1873 protocol=udp
add action=mark-connection chain=prerouting comment="QQ\D2\F4\C0\D6" \
    disabled=no new-connection-mark=Other_Conn passthrough=yes protocol=udp \
    src-port=13010-14000
add action=mark-connection chain=prerouting comment=\
    "\BF\E1\B9\B7\D2\F4\C0\D6" disabled=no new-connection-mark=Other_Conn \
    passthrough=yes protocol=udp src-port=7000
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=udp src-port=\
    21661
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=udp src-port=\
    24729
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=udp src-port=\
    26701
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=udp src-port=\
    29615
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=udp src-port=\
    29095
add action=mark-connection chain=prerouting comment=Xunlei disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=udp src-port=\
    16818
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes port=15000 protocol=udp
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes port=16000-16005 protocol=\
    udp
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=tcp src-port=9006
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=udp src-port=9240
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=tcp src-port=\
    3076-3077
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=udp src-port=\
    15500
add action=mark-connection chain=prerouting comment=\
    "\B3\AC\BC\B6\D0\FD\B7\E7" disabled=no new-connection-mark=Other_Conn \
    passthrough=yes protocol=tcp src-port=4662
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=udp src-port=4663
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=udp src-port=\
    29909
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    29919 new-connection-mark=Other_Conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="PPS\D3\B0\D2\F4" \
    disabled=no new-connection-mark=Other_Conn passthrough=yes port=9701-9750 \
    protocol=udp
add action=mark-connection chain=prerouting comment=\
    "\D1\B8\C0\D7\BF\B4\BF\B4" disabled=no new-connection-mark=Other_Conn \
    passthrough=yes protocol=udp src-port=15500
add action=mark-connection chain=prerouting comment=UC disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=udp src-port=\
    3001-3002
add action=mark-connection chain=prerouting comment=MSN disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=tcp src-port=1863
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=tcp src-port=\
    6891-6900
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=tcp src-port=6901
add action=mark-connection chain=prerouting comment=POPO disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=udp src-port=4001
add action=mark-connection chain=prerouting comment=Yahoo disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=tcp src-port=5050
add action=mark-connection chain=prerouting comment=TaoWanwan disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=tcp src-port=\
    16000
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=tcp src-port=3128
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=udp src-port=1900
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=udp src-port=\
    18000
add action=mark-connection chain=prerouting comment=PPStream disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=udp src-port=1900
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=udp src-port=7201
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes port=9701-9750 protocol=\
    udp
add action=mark-connection chain=prerouting comment=PPlive disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=tcp src-port=8008
add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=Other_Conn passthrough=yes protocol=udp src-port=8008
add action=mark-connection chain=prerouting comment="\C6\E4\CB\FB\CA\FD\BE\DD&\
    \B3\FD\D3\CE\CF\B7\BC\B0WEB\CD\E2&\CB\F9\D3\D0\CA\FD\BE\DD\B0\FC\C0\A8P2P" \
    disabled=no new-connection-mark=Other_Conn passthrough=yes
add action=mark-packet chain=prerouting comment="" connection-mark=Other_Conn \
    disabled=no new-packet-mark=Other_Packet passthrough=no
add action=mark-packet chain=postrouting comment="" connection-mark=\
    Other_Conn disabled=no new-packet-mark=Other_Packet passthrough=no
/queue type
add kind=pcq name=Tel_up pcq-classifier=src-address pcq-limit=50 pcq-rate=\
    1000000 pcq-total-limit=9500
add kind=pcq name=WEB_down pcq-classifier=dst-address pcq-limit=50 pcq-rate=\
    640000 pcq-total-limit=2000
add kind=pcq name=Game_down pcq-classifier=dst-address pcq-limit=50 pcq-rate=\
    500000 pcq-total-limit=9500
add kind=pcq name=Other_down pcq-classifier=dst-address pcq-limit=50 \
    pcq-rate=640000 pcq-total-limit=3500
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=10M name=HTB-Down parent=global-in priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=3M \
    max-limit=10M name=Netgames packet-mark=Port_Packet parent=HTB-Down \
    priority=1 queue=Game_down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=4M \
    max-limit=8M name=Other packet-mark=Other_Packet parent=HTB-Down \
    priority=8 queue=Other_down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=3M \
    max-limit=8M name=Web packet-mark=80_packet parent=HTB-Down priority=2 \
    queue=WEB_down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=10M name=HTB-UP packet-mark=UP_Packet parent=global-out \
    priority=8 queue=Tel_up
赞(0)
未经允许不得转载:Leejoa's 生活随笔 » RouterOS HTB反向标记P2P + 端口优先限速脚本