个人随笔和一些网文摘录
http://www.dlxp.cn

Web-proxy在Router OS中的应用

代理服务器的作用
一、提高访问速度。因为客户要求的数据存于代理服务器的硬盘或内存中,因此下次这个客户或其它客户再要求相同目的站点的数据时,就会直接从代理服务器的硬盘中读取,代理服务器起到了缓存的作用。
二、Proxy可以起到防火墙的作用。因为所有使用代理服务器的用户都必须通过代理服务器访问远程站点,因此在代理服务器上就可以设置相应的限制,以过滤或屏蔽掉某些信息。
三、通过代理服务器可以访问一些不能直接访问的网站。国内的高校多使用教育网,不能出国,但通过代理服务器,就能实现访问因特网,这就是高校内代理服务器热的原因所在。
四、安全性得到提高。无论是上聊天室还是浏览网站,目的网站只能知道你来自于代理服务器,而你的真实IP则无法获知。
配置Web Proxy
命令操作路径:/ip proxy
在web-proxy的setting中选择Enabled启用web代理功能。
Port为代理端口,默认为TCP/8080
通过Cache on disk选择网络数据是否缓存在硬盘中。

现在,设置透明传输数据重定向,将所有访问80端口的数据重定向到web-proxy的8080端口上:

/ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080
设置禁止访问网站,该设置将禁止访问http://www.163.com/
/ip proxy access add dst-host=www.163.com action=deny
我们可用阻止文件如“.mp3, .exe, .dat, .avi”的下载。
[code]/ip proxy access add path=*.exe action=deny
/ip proxy access add path=*.mp3 action=deny
/ip proxy access add path=*.zip action=deny
/ip proxy access add path=*.rar action=deny[/code]

赞(0)
未经允许不得转载:Leejoa's 生活随笔 » Web-proxy在Router OS中的应用